پیکربندی DHCP

پیکربندی کانفیگ DHCP

اطلاعاتی درباره DHCP

پروتکل DHCP که مخفف Dynamic Host Configuration Protocol می باشد یک پروتکل ارتباطاتی است که مدیران شبکه را قادر به مدیریت مرکزی و آدرس دهی ip به صورت اتوماتیک می کند و ضمنا این امکان را به مدیران یک شبکه می دهد که نظارت مستقیمی بر توزیع آدرس های ip از یک نقطه مرکزی داشته باشند و حتی اگر تجهیزات دیگری وارد شبکه شدند بتواند به صورت اتوماتیک به آن ها آدرس ip مربوطه را اختصاص دهد.

از مهمترین مزایای این سرویس به نسبت ست کردن دستی آدرس ip می توان به موارد زیر اشاره کرد:

پیکرببندی های مربوط به ip ها یک جا انجام می شود پس می توانند کاملا تحت کنترل باشند و احتمال رخ دادن خطا در پیکربندی ها را طبیعتا کاهش می دهد.

اجازه تخصیص ip را چه به صورت دائم و چه به صورت موقت فراهم می کند پس سرورها با خروج یک دستگاه از شبکه توانایی بازیابی ip و در نتیجه بهبود عملکرد را دارند.

قابلیت تحرک و جابجایی را فراهم می کند یعنی مثلا اگر یک کاربر با موبایل خود از شبکه ای به شبکه دیگر برود (محیط کار ، منزل و…) می تواند به صورت خودکار از ip های آن شبکه دریافت کند و نیازی به ست کردن دستی نیست پس باز هم احتمال خطا را کاهش می دهد.

مفاهیم DHCP Server ، DHCP Client

سرویس DHCP از جمله سرویس های سرویس گیرنده،  سروری است یعنی آن دستگاهی که سرویس را ارائه می دهد به عنوان سرور و آن دستگاهی که از آن سرویس استفاده می کند تحت عنوان سرویس گیرنده شناخته می شوند پس مهمترین مفهوم های این سرویس DHCP Server و همچنین DHCP Client هستند.پس به زبان ساده می توان گفت دستگاهی که امر اختصاص دادن ip به صورت اتومات و آموزش سایر پیکربندی های ipv4 به سایر نودها را بر عهده دارد DHCP Server و تمامی دستگاه هایی که درخواست در اختیار گرفتن ip به صورت خودکار و همچنین سایر پیکربندی های ipv4 را دارند DHCP Client ها هستند.

مفهوم DHCP Relay Agent

در شبکه های بزرگ معمولا از یک سرور DHCP به ازای هر شبکه استفاده نمی شود بلکه از یک مدل متمرکز شده استفاده می کنند که از نظر عملیاتی بهتر بوده و قابلیت کنترل بهتری نیز دارد و ضمنا می توان آدرس دهی ip را یک جا انجام داد.

در این حالت سرور DHCP در یک LAN مجزا نسبت به سرویس گیرنده ها وجود دارد. از آن جایی که می دانیم پیام های DHCP برادکست هستند و به خارج از محدوده برادکست نمی روند (مثلا مسیریاب ها محدوده ی برادکست را می شکنند و پیام های برادکست را از خود عبور نمی دهند) حال این چالش را چگونه برطرف می کنیم؟

این جا مفهوم DHCP Relay Agent به کمک ما می آید ، به این صورت که مثلا مسیریابی که بسته برادکست به آن رسیده به عنوان نماینده ی بازپخش DHCP Relay Agent معرفی می شود و وقتی بسته ی برادکستی مربوطه به آن برسد ، آن را به سمت سرور DHCP هدایت می کند.

پس طبیعتا باید ارتباط میان مسیریاب نماینده ی بازپخش DHCP و سرور DHCP از طریق آدرس اینترفیسی که شامل کامند ip helper-address است برقرار باشد.

پیش نیازهای DHCP

برای راه اندازی این سرویس در شبکه باید بدانیم چه پارامترهایی از DHCP را در شبکه نیاز داریم و با آن ها آشنایی داشته باشیم و به مفاهیم مربوط به آدرسی دهی ip نیز تسلط کافی داشته باشیم.

از نظر سخت افزاری به تجهیزاتی که قابلیت اجرای این سرویس را دارند، نیاز داریم که به صورت کلی می توان به سرور DHCP،سرویس گیرنده DHCP و همچنین relay agent ها اشاره کرد.

 

نکات پیکربندی DHCP

برای کانفیگ DHCP باید به نکات زیر توجه شود:

  • باید آدرس شبکه و mask آن در سرور DHCP به دقت پیکربندی شود.
  • در صورت نیاز سایر پارامترها مثل dns-server و default-router با دقت تعریف شود.
  • در صورتی که نمی خواهید تعدادی از آدرس های ip از رنج مورد نظر به سرویس گیرنده ها اختصاص داده شوند (به هر دلیلی) آن ها را مجزا کنید.
  • در صورت نیاز به استفاده از DHCP Relay Agent باید ارتباط آن با سرور DHCP برقرار باشد.

 

تنظیمات پیش فرض DHCP

در جدول زیر تنظیمات پیش فرض را مشاهده می کنید:

پیش فرض

ویژگی

غیرفعال

DHCP

به منظور پیکربندی DHCP باید مراحل زیر انجام شود:

خلاصه مراحل

  1. configure terminal
  2. ip dhcp pool word
  3. network B.C.D MA.MB.MC.MD
  4. dns-server B.C.D
  5. default-router B.C.D
  6. ip dhcp excluded-address B.C.D A.B.C.D pool word
  7. ip helper-address B.C.D

جزئیات مراحل

کاربرد

دستور

 

با این دستور وارد محیط کانفیگ سراسری مسیریاب می شویم.

configure terminal

: مثال

zharf-server#configure terminal

zharf-server(config)#

مرحله 1

با این دستور یک pool برای آدرس دهی با یک نام دلخواه ایجاد می کنیم و وارد محیط پیکربندی آن می شویم

ip dhcp pool word

: مثال

zharf-server(config)#ip dhcp pool DHCP

zharf(dhcp-config)#

مرحله 2

با این دستور رنج شبکه مورد نظر برای آدرس دهی را مشخص می کنیم.

network A.B.C.D MA.MB.MC.MD

: مثال

zharf-server(dhcp-config)#network 192.168.1.0 255.255.255.0

مرحله 3

به کمک این دستور آدرس سرور DNS را می توانیم به سرویس گیرنده معرفی کنیم.

dns-server A.B.C.D

: مثال

zharf-server(dhcp-config)#dns-server 192.168.1.100

مرحله 4

به کمک این دستور می توان آدرس gateway را به سرویس گیرنده معرفی کرد.

default-router A.B.C.D

: مثال

zharf-server(dhcp-config)#default-router 192.168.1.1

مرحله 5

جهت مجزا کردن یک رنج از شبکه مورد نظر برای آدرس دهی توسط pool مربوطه از این دستور استفاده می کنیم.

ip dhcp excluded-address A.B.C.D A.B.C.D pool word

: مثال

zharf-server(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10

مرحله 6

به کمک این دستور وارد محیط اینترفیس مسیریاب می شویم.

interface type number

: مثال

zharf-relay(config)#interface gbeth 1

zharf(config-if)#

مرحله 7

جهت معرفی کردن آدرس سرور DHCP در اینترفیس مسیریابی که نقش DHCP Relay Agent دارد از این دستور استفاده می کنیم.

ip helper-address A.B.C.D

: مثال

zharf-relay(config-if)#ip helper-address 192.168.1.1

مرحله 8

با پیکربندی این دستور در اینترفیس مسیریابی که نقش DHCP Client دارد عملا درخواست دریافت آدر ip از سرور DHCP را می دهیم.

ip address dhcp

: مثال

zharf-client(config-if)#ip address dhcp

مرحله 9

در زیر مثالی از  پیکر بندی سرور DHCP را مشاهده می کنید :

zharf-server#configure terminal

zharf-server(config)#ip dhcp pool DHCP

zharf-server(dhcp-config)#network 192.168.1.0 255.255.255.0

zharf-server(dhcp-config)#dns server 192.168.1.100

zharf-server(dhcp-config)#default-router 192.168.1.1

zharf-server(dhcp-config)#exit

zharf-server(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10 pool DHCP

دستورهای پاک کردنی مربوط به DHCP

دستور پاک کردنی خاصی مربوط به DHCP وجود ندارد.

کاربرد

دستور

 

دستورهای نمایشی DHCP

جهت اطمینان از صحت عملکرد DHCP در مسیریاب ژرف از جدول زیر کمک می گیریم:

کاربرد

دستور

به کمک این دستور می توان اطلاعات خلاصه ای از pool های موجود در سرور برای آدرس دهی به سرویس گیرنده های شبکه های موجود را بررسی کرد.

show ip dhcp pool {word}

 

 مثالی از کانفیگ (پیکربندی) DHCP در سرور و سرویس گیرنده

در مثال زیر دستورات مورد نیاز جهت پیکربندی DHCP Server و DHCP Client را در مسیریاب ژرف مشاهده می کنیم:

zharf-server(config)#ip dhcp pool DHCP

zharf-server(dhcp-config)#network 192.168.1.0 255.255.255.0

zharf-server(dhcp-config)#dns server 192.168.1.100

zharf-server(dhcp-config)#default-router 192.168.1.1

zharf-server(dhcp-config)#exit

zharf-server(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10 pool DHCP

zharf-client#configure terminal

zharf-client(config)#interface gbeth 1

zharf-client(config-if)#ip address dhcp

ژرف پویان توس

دیدگاه‌ خود را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

اسکرول به بالا